What’s Vulnerable › Vulnerabilities
CVE-2024-47092: Insecure deserialization and improper certificate validation in Checkmk Exchange plugin check-mk-api
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-03 · updated 2026-06-17
- Weakness: CWE-502
Description
Insecure deserialization and improper certificate validation in Checkmk Exchange plugin check-mk-api prior to 5.8.1
Affected products
- Heinlein-Support Check Mk Python Api: before 5.8.1 — fixed in 5.8.1
How to fix
Upgrade to a fixed version: Heinlein-Support Check Mk Python Api 5.8.1. Check the vendor advisory for mitigations.
References
- https://exchange.checkmk.com/p/check-mk-api
- https://github.com/HeinleinSupport/check_mk_extensions/commit/b5a2a7529e3367d7a643e66f05da4f2a27013904
Get alerted when CVE-2024-47092 or the next vulnerability affects your stack