What’s Vulnerable › Vulnerabilities
CVE-2024-47093: Fix various XSS issues and potential RCE
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-19 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper neutralization of input in Nagvis before version 1.9.42 which can lead to XSS
Affected products
- Nagvis: before 1.9.42 — fixed in 1.9.42
How to fix
Upgrade to a fixed version: Nagvis 1.9.42. Check the vendor advisory for mitigations.
References
- https://github.com/NagVis/nagvis/commit/30e71e8167d17a1828e7da71d6942f6fb36478cd
- https://github.com/NagVis/nagvis/commit/b5b1164007439de526df7d54d5c02d7732ba1c42
- https://www.nagvis.org/downloads/changelog/1.9.42
- https://lists.debian.org/debian-lts-announce/2025/05/msg00000.html
Get alerted when CVE-2024-47093 or the next vulnerability affects your stack