What’s Vulnerable › Vulnerabilities
CVE-2024-47169: Agnai vulnerable to Remote Code Execution via JS Upload using Directory Traversal
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-26 · updated 2026-06-17
- Weakness: CWE-35
Description
Agnai is an artificial-intelligence-agnostic multi-user, mult-bot roleplaying chat system. A vulnerability in versions prior to 1.0.330 permits attackers to upload arbitrary files to attacker-chosen locations on the server, including JavaScript, enabling the execution of commands within those files. This issue could result in unauthorized access, full server compromise, data leakage, and other critical security threats. This does not affect `agnai.chat`, installations using S3-compatible storage, or self-hosting that is not publicly exposed. This does affect publicly hosted installs without S3-compatible storage. Version 1.0.330 fixes this vulnerability.
Affected products
- agnaistic agnai: before 1.0.330 — fixed in 1.0.330
How to fix
Upgrade to a fixed version: agnaistic agnai 1.0.330. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-47169 or the next vulnerability affects your stack