What’s Vulnerable › Vulnerabilities
CVE-2024-47184: Ampache vulnerable to Stored XSS via Democratic Playlist Name
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-09-27 · updated 2026-06-17
- Weakness: CWE-79
Description
Ampache is a web based audio/video streaming application and file manager. Prior to version 6.6.0, the Democratic Playlist Name is vulnerable to a stored cross-site scripting. Version 6.6.0 fixes this issue.
Affected products
- ampache: before 6.6.0 — fixed in 6.6.0
How to fix
Upgrade to a fixed version: ampache 6.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/ampache/ampache/blob/ff332c9810e493fd51b258f5e53119fad86c23bf/public/templates/show_democratic.inc.php#L36
- https://github.com/ampache/ampache/commit/7e64d140dafcbe0d61f1a07e94486f6ed67932d6
- https://github.com/ampache/ampache/security/advisories/GHSA-f99r-gv34-v46f
Get alerted when CVE-2024-47184 or the next vulnerability affects your stack