What’s Vulnerable › Vulnerabilities
CVE-2024-47186: Filament has unvalidated ColorColumn and ColorEntry values that can be used for Cross-site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-27 · updated 2026-06-17
- Weakness: CWE-79
Description
Filament is a collection of full-stack components for Laravel development. Versions of Filament from v3.0.0 through v3.2.114 are affected by a cross-site scripting (XSS) vulnerability. If values passed to a `ColorColumn` or `ColumnEntry` are not valid and contain a specific set of characters, applications are vulnerable to XSS attack against a user who opens a page on which a color column or entry is rendered. Filament v3.2.115 fixes this issue.
Affected products
- filamentphp filament: from 3.0.0 before 3.2.115 — fixed in 3.2.115
How to fix
Upgrade to a fixed version: filamentphp filament 3.2.115. Check the vendor advisory for mitigations.
References
- https://github.com/filamentphp/filament/commit/df7989352464d08eda5837ef50f9997fad902316
- https://github.com/filamentphp/filament/releases/tag/v3.2.115
- https://github.com/filamentphp/filament/security/advisories/GHSA-9h9q-qhxg-89xr
Get alerted when CVE-2024-47186 or the next vulnerability affects your stack