What’s Vulnerable › Vulnerabilities

CVE-2024-47191

Description

pam_oath.so in oath-toolkit 2.6.7 through 2.6.11 before 2.6.12 allows root privilege escalation because, in the context of PAM code running as root, it mishandles usersfile access, such as by calling fchown in the presence of a symlink.

Affected products

How to fix

Upgrade to a fixed version: Nongnu Oath Toolkit 2.6.12. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-47191 or the next vulnerability affects your stack