What’s Vulnerable › Vulnerabilities
CVE-2024-47208: Apache OFBiz: URLs allowing remote use of Groovy expressions, leading to RCE
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-18 · updated 2026-06-17
- Weakness: CWE-94
Description
Server-Side Request Forgery (SSRF), Improper Control of Generation of Code ('Code Injection') vulnerability in Apache OFBiz. This issue affects Apache OFBiz: before 18.12.17. Users are recommended to upgrade to version 18.12.17, which fixes the issue.
Affected products
- Apache Software Foundation Apache OFBiz: before 18.12.17 — fixed in 18.12.17
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache OFBiz 18.12.17. Check the vendor advisory for mitigations.
References
- https://issues.apache.org/jira/browse/OFBIZ-13158
- https://lists.apache.org/thread/022r19skfofhv3lzql33vowlrvqndh11
- https://ofbiz.apache.org/download.html
- https://ofbiz.apache.org/security.html
- http://www.openwall.com/lists/oss-security/2024/11/16/3
Get alerted when CVE-2024-47208 or the next vulnerability affects your stack