What’s Vulnerable › Vulnerabilities
CVE-2024-47210
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-21 · updated 2026-06-17
- Weakness: CWE-400
Description
Gladys Assistant before 4.45.1 allows Privilege Escalation (a user changing their own role) because req.body.role can be used in updateMySelf in server/api/controllers/user.controller.js.
Affected products
- Gladysassistant Gladys Assistant: before 4.45.1 — fixed in 4.45.1
How to fix
Upgrade to a fixed version: Gladysassistant Gladys Assistant 4.45.1. Check the vendor advisory for mitigations.
References
- https://github.com/GladysAssistant/Gladys/commit/344ad9b8ca3078d9292dd95f2dd7b9172bc6ebbe
- https://github.com/GladysAssistant/Gladys/compare/v4.45.0...v4.45.1
- https://github.com/GladysAssistant/Gladys/pull/2115
Get alerted when CVE-2024-47210 or the next vulnerability affects your stack