What’s Vulnerable › Vulnerabilities
CVE-2024-47213
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-03 · updated 2026-06-17
- Weakness: CWE-404
Description
An issue was discovered affecting Enrich 5.1.0 and below. It involves sending a maliciously crafted Snowplow event to the pipeline. Upon receiving this event and trying to validate it, Enrich crashes and attempts to restart indefinitely. As a result, event processing would be halted.
Affected products
- Snowplow Enrich: before 5.1.1 — fixed in 5.1.1
How to fix
Upgrade to a fixed version: Snowplow Enrich 5.1.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-47213 or the next vulnerability affects your stack