What’s Vulnerable › Vulnerabilities
CVE-2024-47248: Apache NimBLE: Buffer overflow in NimBLE MESH Bluetooth stack
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-26 · updated 2026-06-17
- Weakness: CWE-120
Description
Buffer Copy without Checking Size of Input ('Classic Buffer Overflow') vulnerability in Apache NimBLE. Specially crafted MESH message could result in memory corruption when non-default build configuration is used. This issue affects Apache NimBLE: through 1.7.0. Users are recommended to upgrade to version 1.8.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache NimBLE: before 1.8.0 — fixed in 1.8.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache NimBLE 1.8.0. Check the vendor advisory for mitigations.
References
- https://github.com/apache/mynewt-nimble/commit/4f75c0b3b466186beff40e8489870c6cee076aaa
- https://lists.apache.org/thread/z8m7jqh54xybf9kz8q2l3tz92zsj7tmz
- http://www.openwall.com/lists/oss-security/2024/11/26/2
Get alerted when CVE-2024-47248 or the next vulnerability affects your stack