What’s Vulnerable › Vulnerabilities
CVE-2024-47249: Apache NimBLE: Lack of input sanitization leading to out-of-bound reads in multiple advertisement handler
- Severity: medium (CVSS 5.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-26 · updated 2026-06-17
- Weakness: CWE-129
Description
Improper Validation of Array Index vulnerability in Apache NimBLE. Lack of input validation for HCI events from controller could result in out-of-bound memory corruption and crash. This issue requires broken or bogus Bluetooth controller and thus severity is considered low. This issue affects Apache NimBLE: through 1.7.0. Users are recommended to upgrade to version 1.8.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache NimBLE: before 1.8.0 — fixed in 1.8.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache NimBLE 1.8.0. Check the vendor advisory for mitigations.
References
- https://github.com/apache/mynewt-nimble/commit/f39330866a85fa4de49246e9d21334bc8d14f0a1
- https://lists.apache.org/thread/7ckxw6481dp68ons627pjcb27c75n0mq
- http://www.openwall.com/lists/oss-security/2024/11/26/3
Get alerted when CVE-2024-47249 or the next vulnerability affects your stack