What’s Vulnerable › Vulnerabilities
CVE-2024-47250: Apache NimBLE: Lack of input validation in HCI advertising report could lead to potential out-of-bound access
- Severity: medium (CVSS 5.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-26 · updated 2026-06-17
- Weakness: CWE-125
Description
Out-of-bounds Read vulnerability in Apache NimBLE. Missing proper validation of HCI advertising report could lead to out-of-bound access when parsing HCI event and thus bogus GAP 'device found' events being sent. This issue requires broken or bogus Bluetooth controller and thus severity is considered low. This issue affects Apache NimBLE: through 1.7.0. Users are recommended to upgrade to version 1.8.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache NimBLE: before 1.8.0 — fixed in 1.8.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache NimBLE 1.8.0. Check the vendor advisory for mitigations.
References
- https://github.com/apache/mynewt-nimble/commit/23d61150ddae4bc8356356d7ef09d816fb89da45
- https://github.com/apache/mynewt-nimble/commit/3b7a32ea09a3bffaab831ee0ab193a2375fc4df6
- https://lists.apache.org/thread/zdb50spojlqbn0yxd866mbzqjt2vpt85
- http://www.openwall.com/lists/oss-security/2024/11/26/4
Get alerted when CVE-2024-47250 or the next vulnerability affects your stack