What’s Vulnerable › Vulnerabilities
CVE-2024-47259
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-04 · updated 2026-06-17
- Weakness: CWE-434
Description
Girishunawane, member of the AXIS OS Bug Bounty Program, has found that the VAPIX API dynamicoverlay.cgi did not have a sufficient input validation allowing for a possible command injection leading to being able to transfer files to the Axis device with the purpose to exhaust system resources. Axis has released patched AXIS OS versions for the highlighted flaw. Please refer to the Axis security advisory for more information and solution.
Affected products
- Axis Communications AB AXIS OS: from 11.11.0 before 12.2.52 — fixed in 12.2.52
- Axis Os 2024: before 11.11.126 — fixed in 11.11.126
How to fix
Upgrade to a fixed version: Axis Communications AB AXIS OS 12.2.52; Axis Os 2024 11.11.126. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-47259 or the next vulnerability affects your stack