What’s Vulnerable › Vulnerabilities
CVE-2024-47325: WordPress Multiple Page Generator Plugin – MPG plugin <= 3.4.7 - SQL Injection vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-20 · updated 2026-06-17
- Weakness: CWE-89
Description
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Themeisle MPG multiple-pages-generator-by-porthas allows SQL Injection.This issue affects MPG: from n/a through <= 3.4.7.
Affected products
- themeisle Multiple Page Generator Plugin – MPG: before 3.4.8 — fixed in 3.4.8
How to fix
Upgrade to a fixed version: themeisle Multiple Page Generator Plugin – MPG 3.4.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-47325 or the next vulnerability affects your stack