What’s Vulnerable › Vulnerabilities
CVE-2024-47384: WordPress WP Compress plugin <= 6.20.13 - Reflected Cross Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-05 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in AresIT WP Compress wp-compress-image-optimizer allows Reflected XSS.This issue affects WP Compress: from n/a through <= 6.20.13.
Affected products
- aresit WP Compress – Instant Performance & Speed Optimization: before 6.21.01 — fixed in 6.21.01
How to fix
Upgrade to a fixed version: aresit WP Compress – Instant Performance & Speed Optimization 6.21.01. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-47384 or the next vulnerability affects your stack