What’s Vulnerable › Vulnerabilities

CVE-2024-47401: DoS via Amplified GraphQL Response in Playbooks

Description

Mattermost versions 9.10.x <= 9.10.2, 9.11.x <= 9.11.1 and 9.5.x <= 9.5.9 fail to prevent detailed error messages from being displayed in Playbooks which allows an attacker to generate a large response and cause an amplified GraphQL response which in turn could cause the application to crash by sending a specially crafted request to Playbooks.

Affected products

How to fix

Upgrade to a fixed version: Mattermost 9.10.3, 9.11.2, 9.5.10. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-47401 or the next vulnerability affects your stack