What’s Vulnerable › Vulnerabilities
CVE-2024-47450: Illustrator | Heap-based Buffer Overflow (CWE-122)
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-12 · updated 2026-06-17
- Weakness: CWE-122
Description
Illustrator versions 28.7.1 and earlier are affected by a Heap-based Buffer Overflow vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe Illustrator: before 28.7.2 — fixed in 28.7.2
How to fix
Upgrade to a fixed version: Adobe Illustrator 28.7.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-47450 or the next vulnerability affects your stack