What’s Vulnerable › Vulnerabilities
CVE-2024-47456: Illustrator | Out-of-bounds Read (CWE-125)
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-12 · updated 2026-06-17
- Weakness: CWE-125
Description
Illustrator versions 28.7.1 and earlier are affected by an out-of-bounds read vulnerability that could lead to disclosure of sensitive memory. An attacker could leverage this vulnerability to bypass mitigations such as ASLR. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe Illustrator: before 28.7.2 — fixed in 28.7.2
How to fix
Upgrade to a fixed version: Adobe Illustrator 28.7.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-47456 or the next vulnerability affects your stack