What’s Vulnerable › Vulnerabilities
CVE-2024-47460: Unauthenticated Command Injection Vulnerability in the CLI Service Accessed by the PAPI Protocol
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-05 · updated 2026-06-17
- Weakness: CWE-77
Description
Command injection vulnerability in the underlying CLI service could lead to unauthenticated remote code execution by sending specially crafted packets destined to the PAPI (Aruba's Access Point management protocol) UDP port (8211). Successful exploitation of this vulnerability results in the ability to execute arbitrary code as a privileged user on the underlying operating system.
Affected products
- Hewlett Packard Enterprise (HPE) ArubaOS (AOS): from 10.4.0.0 through 10.4.1.4; from 10.3.0.0 before 10.4.0.0; from 10.5.0.0 before 10.7.0.0 — fixed in 10.4.0.0, 10.7.0.0
- Arubanetworks Instant: from 8.12.0.0 through 8.12.0.2; from 8.10.0.0 through 8.10.0.13; from 6.4.0.0 before 6.6.0.0; from 8.4.0.0 before 8.10.0.0; from 8.11.0.0 before 8.12.0.0 — fixed in 6.6.0.0, 8.10.0.0, 8.12.0.0
How to fix
Upgrade to a fixed version: Hewlett Packard Enterprise (HPE) ArubaOS (AOS) 10.4.0.0, 10.7.0.0; Arubanetworks Instant 6.6.0.0, 8.10.0.0, 8.12.0.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-47460 or the next vulnerability affects your stack