What’s Vulnerable › Vulnerabilities
CVE-2024-4749: WP eMember < 10.3.9 - Reflected XSS
- Severity: high (CVSS 8.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-06-04 · updated 2026-06-17
- Weakness: CWE-79
Description
The wp-eMember WordPress plugin before 10.3.9 does not sanitize and escape the "fieldId" parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting.
Affected products
- wp-eMember: before 10.3.9 — fixed in 10.3.9
How to fix
Upgrade to a fixed version: wp-eMember 10.3.9. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/6cc05a33-6592-4d35-8e66-9b6a9884df7e/
- https://wpscan.com/vulnerability/6cc05a33-6592-4d35-8e66-9b6a9884df7e/
Get alerted when CVE-2024-4749 or the next vulnerability affects your stack