What’s Vulnerable › Vulnerabilities
CVE-2024-4752: EventON < 2.2.15 - Admin+ Stored Cross-Site Scripting via event subtitle
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The EventON WordPress plugin before 2.2.15 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- EventON: before 2.2.15 — fixed in 2.2.15
How to fix
Upgrade to a fixed version: EventON 2.2.15. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/70d1f5d5-1a96-494b-9203-96a7780026da/
- https://wpscan.com/vulnerability/70d1f5d5-1a96-494b-9203-96a7780026da/
Get alerted when CVE-2024-4752 or the next vulnerability affects your stack