What’s Vulnerable › Vulnerabilities
CVE-2024-47523: LibreNMS has Stored Cross-site Scripting vulnerability in "Alert Transports" feature
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-10-01 · updated 2026-06-17
- Weakness: CWE-79
Description
LibreNMS is an open-source, PHP/MySQL/SNMP-based network monitoring system. A Stored Cross-Site Scripting (XSS) vulnerability in the "Alert Transports" feature allows authenticated users to inject arbitrary JavaScript through the "Details" section (which contains multiple fields depending on which transport is selected at that moment). This vulnerability can lead to the execution of malicious code in the context of other users' sessions, potentially compromising their accounts and allowing unauthorized actions. This vulnerability is fixed in 24.9.0.
Affected products
- librenms: before 24.9.0 — fixed in 24.9.0
How to fix
Upgrade to a fixed version: librenms 24.9.0. Check the vendor advisory for mitigations.
References
- https://github.com/librenms/librenms/blob/4777247327c793ed0a3306d0464b95176008177b/includes/html/print-alert-transports.php#L40
- https://github.com/librenms/librenms/commit/ee1afba003d33667981e098c83295f599d88439c
- https://github.com/librenms/librenms/security/advisories/GHSA-7f84-28qh-9486
Get alerted when CVE-2024-47523 or the next vulnerability affects your stack