What’s Vulnerable › Vulnerabilities
CVE-2024-47524: LibreNMS has Stored Cross-site Scripting vulnerability in "Device Group" Name
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-10-01 · updated 2026-06-17
- Weakness: CWE-79
Description
LibreNMS is an open-source, PHP/MySQL/SNMP-based network monitoring system. User with Admin role can create a Device Groups, the application did not properly sanitize the user input in the Device Groups name, when user see the detail of the Device Group, if java script code is inside the name of the Device Groups, its will be trigger. This vulnerability is fixed in 24.9.0.
Affected products
- librenms: before 24.9.0 — fixed in 24.9.0
How to fix
Upgrade to a fixed version: librenms 24.9.0. Check the vendor advisory for mitigations.
References
- https://github.com/librenms/librenms/commit/d3b51560a8e2343e520d16e9adc72c6951aa91ee
- https://github.com/librenms/librenms/security/advisories/GHSA-fc38-2254-48g7
Get alerted when CVE-2024-47524 or the next vulnerability affects your stack