What’s Vulnerable › Vulnerabilities
CVE-2024-47527: LibreNMS has a Stored XSS ('Cross-site Scripting') in librenms/includes/html/pages/device-dependencies.inc.php
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-10-01 · updated 2026-06-17
- Weakness: CWE-79
Description
LibreNMS is an open-source, PHP/MySQL/SNMP-based network monitoring system. A Stored Cross-Site Scripting (XSS) vulnerability in the "Device Dependencies" feature allows authenticated users to inject arbitrary JavaScript through the device name ("hostname" parameter). This vulnerability can lead to the execution of malicious code in the context of other users' sessions, potentially compromising their accounts and allowing unauthorized actions. This vulnerability is fixed in 24.9.0.
Affected products
- librenms: before 24.9.0 — fixed in 24.9.0
How to fix
Upgrade to a fixed version: librenms 24.9.0. Check the vendor advisory for mitigations.
References
- https://github.com/librenms/librenms/commit/36b38a50cc10d4ed16caab92bdc18ed6abac9685
- https://github.com/librenms/librenms/security/advisories/GHSA-rwwc-2v8q-gc9v
Get alerted when CVE-2024-47527 or the next vulnerability affects your stack