What’s Vulnerable › Vulnerabilities
CVE-2024-47528: LibreNMS Contains a Stored XSS via File Upload
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-10-01 · updated 2026-06-17
- Weakness: CWE-79
Description
LibreNMS is an open-source, PHP/MySQL/SNMP-based network monitoring system. Stored Cross-Site Scripting (XSS) can be achieved by uploading a new Background for a Custom Map. Users with "admin" role can set background for a custom map, this allow the upload of SVG file that can contain XSS payload which will trigger on load. This led to Stored Cross-Site Scripting (XSS). The vulnerability is fixed in 24.9.0.
Affected products
- librenms: before 24.9.0 — fixed in 24.9.0
How to fix
Upgrade to a fixed version: librenms 24.9.0. Check the vendor advisory for mitigations.
References
- https://github.com/librenms/librenms/commit/d959bf1b366319eda16e3cd6dfda8a22beb203be
- https://github.com/librenms/librenms/security/advisories/GHSA-x8gm-j36p-fppf
Get alerted when CVE-2024-47528 or the next vulnerability affects your stack