What’s Vulnerable › Vulnerabilities
CVE-2024-4753: WP Secure Maintenance < 1.7 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-12 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Secure Maintenance WordPress plugin before 1.7 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- WP Secure Maintenance: before 1.7 — fixed in 1.7
How to fix
Upgrade to a fixed version: WP Secure Maintenance 1.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/81725b17-532a-43e6-8ce5-fe50a2ed0819/
- https://wpscan.com/vulnerability/81725b17-532a-43e6-8ce5-fe50a2ed0819/
Get alerted when CVE-2024-4753 or the next vulnerability affects your stack