What’s Vulnerable › Vulnerabilities
CVE-2024-47533: Cobbler allows anyone to connect to cobbler XML-RPC server with a known password and make changes
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-11-18 · updated 2026-06-17
- Weakness: CWE-287
Description
Cobbler, a Linux installation server that allows for rapid setup of network installation environments, has an improper authentication vulnerability starting in version 3.0.0 and prior to versions 3.2.3 and 3.3.7. `utils.get_shared_secret()` always returns `-1`, which allows anyone to connect to cobbler XML-RPC as user `''` password `-1` and make any changes. This gives anyone with network access to a cobbler server full control of the server. Versions 3.2.3 and 3.3.7 fix the issue.
Affected products
- The cobbler Project cobbler: from 3.0.0 before 3.2.3; from 3.3.0 before 3.3.7 — fixed in 3.2.3, 3.3.7
How to fix
Upgrade to a fixed version: The cobbler Project cobbler 3.2.3, 3.3.7. Check the vendor advisory for mitigations.
References
- https://github.com/cobbler/cobbler/commit/32c5cada013dc8daa7320a8eda9932c2814742b0
- https://github.com/cobbler/cobbler/commit/e19717623c10b29e7466ed4ab23515a94beb2dda
- https://github.com/cobbler/cobbler/security/advisories/GHSA-m26c-fcgh-cp6h
Get alerted when CVE-2024-47533 or the next vulnerability affects your stack