What’s Vulnerable › Vulnerabilities
CVE-2024-47541: GHSL-2024-228: GStreamer has an out-of-bounds write in SSA subtitle parser
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-12-12 · updated 2026-06-17
- Weakness: CWE-787
Description
GStreamer is a library for constructing graphs of media-handling components. An OOB-write vulnerability has been identified in the gst_ssa_parse_remove_override_codes function of the gstssaparse.c file. This function is responsible for parsing and removing SSA (SubStation Alpha) style override codes, which are enclosed in curly brackets ({}). The issue arises when a closing curly bracket "}" appears before an opening curly bracket "{" in the input string. In this case, memmove() incorrectly duplicates a substring. With each successive loop iteration, the size passed to memmove() becomes progressively larger (strlen(end+1)), leading to a write beyond the allocated memory bounds. This vulnerability is fixed in 1.24.10.
Affected products
- GStreamer: before 1.24.10 — fixed in 1.24.10
How to fix
Upgrade to a fixed version: GStreamer 1.24.10. Check the vendor advisory for mitigations.
References
- https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/8036.patch
- https://gstreamer.freedesktop.org/security/sa-2024-0023.html
- https://securitylab.github.com/advisories/GHSL-2024-228_GStreamer/
- https://lists.debian.org/debian-lts-announce/2024/12/msg00021.html
Get alerted when CVE-2024-47541 or the next vulnerability affects your stack