What’s Vulnerable › Vulnerabilities
CVE-2024-47543: GHSL-2024-236: GStreamer has an OOB-read in qtdemux_parse_container
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-12 · updated 2026-06-17
- Weakness: CWE-125
Description
GStreamer is a library for constructing graphs of media-handling components. An OOB-read vulnerability has been discovered in qtdemux_parse_container function within qtdemux.c. In the parent function qtdemux_parse_node, the value of length is not well checked. So, if length is big enough, it causes the pointer end to point beyond the boundaries of buffer. Subsequently, in the qtdemux_parse_container function, the while loop can trigger an OOB-read, accessing memory beyond the bounds of buf. This vulnerability can result in reading up to 4GB of process memory or potentially causing a segmentation fault (SEGV) when accessing invalid memory. This vulnerability is fixed in 1.24.10.
Affected products
- GStreamer: before 1.24.10 — fixed in 1.24.10
How to fix
Upgrade to a fixed version: GStreamer 1.24.10. Check the vendor advisory for mitigations.
References
- https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/8059.patch
- https://gstreamer.freedesktop.org/security/sa-2024-0009.html
- https://securitylab.github.com/advisories/GHSL-2024-236_Gstreamer/
- https://lists.debian.org/debian-lts-announce/2025/02/msg00035.html
Get alerted when CVE-2024-47543 or the next vulnerability affects your stack