What’s Vulnerable › Vulnerabilities

CVE-2024-47570

Description

An insertion of sensitive information into log file vulnerability [CWE-532] in FortiOS 7.4.0 through 7.4.3, 7.2.0 through 7.2.7, 7.0 all versions; FortiProxy 7.4.0 through 7.4.3, 7.2.0 through 7.2.11; FortiPAM 1.4 all versions, 1.3 all versions, 1.2 all versions, 1.1 all versions, 1.0 all versions and FortiSRA 1.4 all versions may allow a read-only administrator to retrieve API tokens of other administrators via observing REST API logs, if REST API logging is enabled (non-default configuration).

Affected products

How to fix

Upgrade to a fixed version: Fortinet FortiOS (FortiGate) 7.2.8, 7.4.4; Fortinet FortiProxy 7.2.12, 7.4.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-47570 or the next vulnerability affects your stack