What’s Vulnerable › Vulnerabilities
CVE-2024-47598: GHSL-2024-246: GStreamer has an OOB-read in qtdemux_merge_sample_table
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-12 · updated 2026-06-17
- Weakness: CWE-125
Description
GStreamer is a library for constructing graphs of media-handling components. An OOB-read vulnerability has been discovered in the qtdemux_merge_sample_table function within qtdemux.c. The problem is that the size of the stts buffer isn’t properly checked before reading stts_duration, allowing the program to read 4 bytes beyond the boundaries of stts->data. This vulnerability reads up to 4 bytes past the allocated bounds of the stts array. This vulnerability is fixed in 1.24.10.
Affected products
- GStreamer: before 1.24.10 — fixed in 1.24.10
How to fix
Upgrade to a fixed version: GStreamer 1.24.10. Check the vendor advisory for mitigations.
References
- https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/8059.patch
- https://gstreamer.freedesktop.org/security/sa-2024-0006.html
- https://securitylab.github.com/advisories/GHSL-2024-246_Gstreamer/
- https://lists.debian.org/debian-lts-announce/2025/02/msg00035.html
Get alerted when CVE-2024-47598 or the next vulnerability affects your stack