What’s Vulnerable › Vulnerabilities
CVE-2024-47610: Stored Cross-site Scripting Vulnerability in Markdown Editor
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-07 · updated 2026-06-17
- Weakness: CWE-79
Description
InvenTree is an Open Source Inventory Management System. In affected versions of InvenTree it is possible for a registered user to store javascript in markdown notes fields, which are then displayed to other logged in users who visit the same page and executed. The vulnerability has been addressed as follows: 1. HTML sanitization has been enabled in the front-end markdown rendering library - `easymde`. 2. Stored markdown is also validated on the backend, to ensure that malicious markdown is not stored in the database. These changes are available in release versions 0.16.5 and later. All users are advised to upgrade. There are no workarounds, an update is required to get the new validation functions.
Affected products
- InvenTree: before 0.16.5 — fixed in 0.16.5
How to fix
Upgrade to a fixed version: InvenTree 0.16.5. Check the vendor advisory for mitigations.
References
- https://github.com/inventree/InvenTree/commit/6e37f0cd8ba5fc527412f18f66cd6a37015fa690
- https://github.com/inventree/InvenTree/security/advisories/GHSA-wp3m-jhgv-rhqr
Get alerted when CVE-2024-47610 or the next vulnerability affects your stack