What’s Vulnerable › Vulnerabilities
CVE-2024-47614: async-graphql vulnerable to Directive Overload
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-03 · updated 2026-06-17
- Weakness: CWE-770
Description
async-graphql is a GraphQL server library implemented in Rust. async-graphql before 7.0.10 does not limit the number of directives for a field. This can lead to Service Disruption, Resource Exhaustion, and User Experience Degradation. This vulnerability is fixed in 7.0.10.
Affected products
- graphql Async-Graphql: before 7.0.10 — fixed in 7.0.10
How to fix
Upgrade to a fixed version: graphql Async-Graphql 7.0.10. Check the vendor advisory for mitigations.
References
- https://github.com/async-graphql/async-graphql/commit/7f1791488463d4e9c5adcd543962173e2f6cbd34
- https://github.com/async-graphql/async-graphql/security/advisories/GHSA-5gc2-7c65-8fq8
Get alerted when CVE-2024-47614 or the next vulnerability affects your stack