What’s Vulnerable › Vulnerabilities
CVE-2024-47663: staging: iio: frequency: ad9834: Validate frequency parameter value
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-09 · updated 2026-06-17
- Weakness: CWE-369
Description
In the Linux kernel, the following vulnerability has been resolved: staging: iio: frequency: ad9834: Validate frequency parameter value In ad9834_write_frequency() clk_get_rate() can return 0. In such case ad9834_calc_freqreg() call will lead to division by zero. Checking 'if (fout > (clk_freq / 2))' doesn't protect in case of 'fout' is 0. ad9834_write_frequency() is called from ad9834_write(), where fout is taken from text buffer, which can contain any value. Modify parameters checking. Found by Linux Verification Center (linuxtesting.org) with SVACE.
Affected products
- Linux kernel: from 2.6.38 before 5.4.284; from 5.5 before 5.10.226; from 5.11 before 5.15.167; from 5.16 before 6.1.110; from 6.2 before 6.6.51; from 6.7 before 6.10.10 — fixed in 5.10.226, 5.15.167, 5.4.284, 6.1.110, 6.10.10, 6.6.51
How to fix
Upgrade to a fixed version: Linux kernel 5.10.226, 5.15.167, 5.4.284, 6.1.110. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0e727707a239d5c519fc9abc2f0fd913516a7e47
- https://git.kernel.org/stable/c/3ba9abfcaa9e16bb91ed7e0e2b42e94a157a953e
- https://git.kernel.org/stable/c/41cc91e3138fe52f8da92a81bebcd0e6cf488c53
- https://git.kernel.org/stable/c/5edc3a45ef428501000a7b23d0e1777a548907f6
- https://git.kernel.org/stable/c/8961b245e8f92bccbaacfbbdf69eba60e3e7c227
- https://git.kernel.org/stable/c/b48aa991758999d4e8f9296c5bbe388f293ef465
- https://git.kernel.org/stable/c/d8b09a5edc4a634373158c1a405491de3c52e58a
- https://git.kernel.org/stable/c/dc12e49f970b08d8b007b8981b97e2eb93c0e89d
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
Get alerted when CVE-2024-47663 or the next vulnerability affects your stack