What’s Vulnerable › Vulnerabilities
CVE-2024-47670: ocfs2: add bounds checking to ocfs2_xattr_find_entry()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-09 · updated 2026-08-04
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: ocfs2: add bounds checking to ocfs2_xattr_find_entry() Add a paranoia check to make sure it doesn't stray beyond valid memory region containing ocfs2 xattr entries when scanning for a match. It will prevent out-of-bound access in case of crafted images.
Affected products
- Linux kernel: before 6.1.112; from 6.2 before 6.6.53; from 6.7 before 6.10.12 — fixed in 6.1.112, 6.10.12, 6.6.53
How to fix
Upgrade to a fixed version: Linux kernel 6.1.112, 6.10.12, 6.6.53. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/1f6e167d6753fe3ea493cdc7f7de8d03147a4d39
- https://git.kernel.org/stable/c/34759b7e4493d7337cbc414c132cef378c492a2c
- https://git.kernel.org/stable/c/5bbe51eaf01a5dd6fb3f0dea81791e5dbc6dc6dd
- https://git.kernel.org/stable/c/60c0d36189bad58b1a8e69af8781d90009559ea1
- https://git.kernel.org/stable/c/8e7bef408261746c160853fc27df3139659f5f77
- https://git.kernel.org/stable/c/9b32539590a8e6400ac2f6e7cf9cbb8e08711a2f
- https://git.kernel.org/stable/c/9e3041fecdc8f78a5900c3aa51d3d756e73264d6
- https://git.kernel.org/stable/c/b49a786beb11ff740cb9e0c20b999c2a0e1729c2
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
- https://lists.debian.org/debian-lts-announce/2025/03/msg00002.html
Get alerted when CVE-2024-47670 or the next vulnerability affects your stack