What’s Vulnerable › Vulnerabilities
CVE-2024-47730: crypto: hisilicon/qm - inject error before stopping queue
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-21 · updated 2026-08-04
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: crypto: hisilicon/qm - inject error before stopping queue The master ooo cannot be completely closed when the accelerator core reports memory error. Therefore, the driver needs to inject the qm error to close the master ooo. Currently, the qm error is injected after stopping queue, memory may be released immediately after stopping queue, causing the device to access the released memory. Therefore, error is injected to close master ooo before stopping queue to ensure that the device does not access the released memory.
Affected products
- Debian Linux: 11.0
- Linux kernel: from 5.8 before 5.10.235; from 5.11 before 5.15.174; from 5.16 before 6.1.113; from 6.2 before 6.6.54; from 6.7 before 6.10.13; from 6.11 before 6.11.2 — fixed in 5.10.235, 5.15.174, 6.1.113, 6.10.13, 6.11.2, 6.6.54
How to fix
Upgrade to a fixed version: Linux kernel 5.10.235, 5.15.174, 6.1.113, 6.10.13. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/801d64177faaec184cee1e1aa4d8487df1364a54
- https://git.kernel.org/stable/c/85e81103033324d7a271dafb584991da39554a89
- https://git.kernel.org/stable/c/98d3be34c9153eceadb56de50d9f9347e88d86e4
- https://git.kernel.org/stable/c/aa3e0db35a60002fb34ef0e4ad203aa59fd00203
- https://git.kernel.org/stable/c/b04f06fc0243600665b3b50253869533b7938468
- https://git.kernel.org/stable/c/c5f5b813e546f7fe133539c3d7a5086cc8dd2aa1
- https://git.kernel.org/stable/c/f8024f12752e32ffbbf59e1c09d949f977ff743f
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
- https://lists.debian.org/debian-lts-announce/2025/05/msg00030.html
Get alerted when CVE-2024-47730 or the next vulnerability affects your stack