What’s Vulnerable › Vulnerabilities
CVE-2024-47750: RDMA/hns: Fix Use-After-Free of rsv_qp on HIP08
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-21 · updated 2026-08-04
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: RDMA/hns: Fix Use-After-Free of rsv_qp on HIP08 Currently rsv_qp is freed before ib_unregister_device() is called on HIP08. During the time interval, users can still dereg MR and rsv_qp will be used in this process, leading to a UAF. Move the release of rsv_qp after calling ib_unregister_device() to fix it.
Affected products
- Linux kernel: from 5.18 before 6.1.113; from 6.2 before 6.6.54; from 6.7 before 6.10.13; from 6.11 before 6.11.2 — fixed in 6.1.113, 6.10.13, 6.11.2, 6.6.54
How to fix
Upgrade to a fixed version: Linux kernel 6.1.113, 6.10.13, 6.11.2, 6.6.54. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/2ccf1c75d39949d8ea043d04a2e92d7100ea723d
- https://git.kernel.org/stable/c/60595923371c2ebe7faf82536c47eb0c967e3425
- https://git.kernel.org/stable/c/d2d9c5127122745da6e887f451dd248cfeffca33
- https://git.kernel.org/stable/c/dac2723d8bfa9cf5333f477741e6e5fa1ed34645
- https://git.kernel.org/stable/c/fd8489294dd2beefb70f12ec4f6132aeec61a4d0
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
Get alerted when CVE-2024-47750 or the next vulnerability affects your stack