What’s Vulnerable › Vulnerabilities
CVE-2024-47751: PCI: kirin: Fix buffer overflow in kirin_pcie_parse_port()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-21 · updated 2026-06-17
- Weakness: CWE-120
Description
In the Linux kernel, the following vulnerability has been resolved: PCI: kirin: Fix buffer overflow in kirin_pcie_parse_port() Within kirin_pcie_parse_port(), the pcie->num_slots is compared to pcie->gpio_id_reset size (MAX_PCI_SLOTS) which is correct and would lead to an overflow. Thus, fix condition to pcie->num_slots + 1 >= MAX_PCI_SLOTS and move pcie->num_slots increment below the if-statement to avoid out-of-bounds array access. Found by Linux Verification Center (linuxtesting.org) with SVACE. [kwilczynski: commit log]
Affected products
- Linux kernel: from 5.16 before 6.1.113; from 6.2 before 6.6.54; from 6.7 before 6.10.13; from 6.11 before 6.11.2 — fixed in 6.1.113, 6.10.13, 6.11.2, 6.6.54
How to fix
Upgrade to a fixed version: Linux kernel 6.1.113, 6.10.13, 6.11.2, 6.6.54. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/6dcc5b49d6607a741a14122bf3105f3ac50d259e
- https://git.kernel.org/stable/c/95248d7497bcbfe7deed4805469c6ff6ddd7f9d1
- https://git.kernel.org/stable/c/a5f795f9412854df28e66679c5e6b68b0b79c229
- https://git.kernel.org/stable/c/aeb0335971806e15ac91e838ca471936c8e7efd5
- https://git.kernel.org/stable/c/c500a86693a126c9393e602741e348f80f1b0fc5
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
Get alerted when CVE-2024-47751 or the next vulnerability affects your stack