What’s Vulnerable › Vulnerabilities
CVE-2024-47756: PCI: keystone: Fix if-statement expression in ks_pcie_quirk()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-21 · updated 2026-06-17
- Weakness: CWE-476
Description
In the Linux kernel, the following vulnerability has been resolved: PCI: keystone: Fix if-statement expression in ks_pcie_quirk() This code accidentally uses && where || was intended. It potentially results in a NULL dereference. Thus, fix the if-statement expression to use the correct condition. [kwilczynski: commit log]
Affected products
- Linux kernel: from 5.4.284 before 5.5; from 6.1.110 before 6.1.113; from 6.6.51 before 6.6.54; from 6.10.10 before 6.10.13; from 6.11 before 6.11.2; 5.10.226, 5.15.167 — fixed in 5.5, 6.1.113, 6.10.13, 6.11.2, 6.6.54
How to fix
Upgrade to a fixed version: Linux kernel 5.5, 6.1.113, 6.10.13, 6.11.2. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/2171c5cb2fbc3e03af7e8116cd58736c09328655
- https://git.kernel.org/stable/c/23838bef2adb714ec37b2d6141dccf4a3a70bdef
- https://git.kernel.org/stable/c/6188a1c762eb9bbd444f47696eda77a5eae6207a
- https://git.kernel.org/stable/c/72210e52e19a27f615e0b5273d2bf012d0dc318d
- https://git.kernel.org/stable/c/9c9afc3e75069fcfb067727973242cfbf00dd7eb
- https://git.kernel.org/stable/c/c289903b7a216df5ea6e1850ddf1b958eea9921d
- https://git.kernel.org/stable/c/dc5aeba07395c8dfa29bb878c8ce4d5180427221
- https://git.kernel.org/stable/c/e85ab507882db165c10a858d7f685a0a38f0312e
- https://lists.debian.org/debian-lts-announce/2025/01/msg00001.html
- https://lists.debian.org/debian-lts-announce/2025/03/msg00002.html
Get alerted when CVE-2024-47756 or the next vulnerability affects your stack