What’s Vulnerable › Vulnerabilities
CVE-2024-47759: GLPI has a stored XSS via document upload
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-15 · updated 2026-06-17
- Weakness: CWE-79
Description
GLPI is a free Asset and IT management software package. An technician can upload a SVG containing a malicious script. The script will then be executed when any user will try to see the document contents. Upgrade to 10.0.17.
Affected products
- glpi-project glpi: from 9.2.0 before 10.0.17 — fixed in 10.0.17
How to fix
Upgrade to a fixed version: glpi-project glpi 10.0.17. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-47759 or the next vulnerability affects your stack