What’s Vulnerable › Vulnerabilities
CVE-2024-47774: GHSL-2024-262: GStreamer has an OOB-read in gst_avi_subtitle_parse_gab2_chunk
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-12 · updated 2026-06-17
- Weakness: CWE-125
Description
GStreamer is a library for constructing graphs of media-handling components. An OOB-read vulnerability has been identified in the gst_avi_subtitle_parse_gab2_chunk function within gstavisubtitle.c. The function reads the name_length value directly from the input file without checking it properly. Then, the a condition, does not properly handle cases where name_length is greater than 0xFFFFFFFF - 17, causing an integer overflow. In such scenario, the function attempts to access memory beyond the buffer leading to an OOB-read. This vulnerability is fixed in 1.24.10.
Affected products
- GStreamer: before 1.24.10 — fixed in 1.24.10
How to fix
Upgrade to a fixed version: GStreamer 1.24.10. Check the vendor advisory for mitigations.
References
- https://github.com/github/securitylab-vulnerabilities/issues/1826
- https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/8043.patch
- https://securitylab.github.com/advisories/GHSL-2024-262_Gstreamer/
- https://lists.debian.org/debian-lts-announce/2025/02/msg00035.html
Get alerted when CVE-2024-47774 or the next vulnerability affects your stack