What’s Vulnerable › Vulnerabilities
CVE-2024-47776: GHSL-2024-260: GStreamer has a OOB-read in gst_wavparse_cue_chunk
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-12 · updated 2026-06-17
- Weakness: CWE-125
Description
GStreamer is a library for constructing graphs of media-handling components. An OOB-read has been discovered in gst_wavparse_cue_chunk within gstwavparse.c. The vulnerability happens due to a discrepancy between the size of the data buffer and the size value provided to the function. This mismatch causes the comparison if (size < 4 + ncues * 24) to fail in some cases, allowing the subsequent loop to access beyond the bounds of the data buffer. The root cause of this discrepancy stems from a miscalculation when clipping the chunk size based on upstream data size. This vulnerability allows reading beyond the bounds of the data buffer, potentially leading to a crash (denial of service) or the leak of sensitive data. This vulnerability is fixed in 1.24.10.
Affected products
- GStreamer: before 1.24.10 — fixed in 1.24.10
How to fix
Upgrade to a fixed version: GStreamer 1.24.10. Check the vendor advisory for mitigations.
References
- https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/8042.patch
- https://gstreamer.freedesktop.org/security/sa-2024-0027.html
- https://securitylab.github.com/advisories/GHSL-2024-260_Gstreamer/
- https://lists.debian.org/debian-lts-announce/2025/02/msg00035.html
Get alerted when CVE-2024-47776 or the next vulnerability affects your stack