What’s Vulnerable › Vulnerabilities
CVE-2024-47777: GHSL-2024-259: GStreamer has an OOB-read in gst_wavparse_smpl_chunk
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-12 · updated 2026-06-17
- Weakness: CWE-125
Description
GStreamer is a library for constructing graphs of media-handling components. An OOB-read vulnerability has been identified in the gst_wavparse_smpl_chunk function within gstwavparse.c. This function attempts to read 4 bytes from the data + 12 offset without checking if the size of the data buffer is sufficient. If the buffer is too small, the function reads beyond its bounds. This vulnerability may result in reading 4 bytes out of the boundaries of the data buffer. This vulnerability is fixed in 1.24.10.
Affected products
- GStreamer: before 1.24.10 — fixed in 1.24.10
How to fix
Upgrade to a fixed version: GStreamer 1.24.10. Check the vendor advisory for mitigations.
References
- https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/8042.patch
- https://gstreamer.freedesktop.org/security/sa-2024-0027.html
- https://securitylab.github.com/advisories/GHSL-2024-259_Gstreamer/
- https://lists.debian.org/debian-lts-announce/2025/02/msg00035.html
Get alerted when CVE-2024-47777 or the next vulnerability affects your stack