What’s Vulnerable › Vulnerabilities
CVE-2024-47814: use-after-free when closing buffers in Vim
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-07 · updated 2026-06-17
- Weakness: CWE-416
Description
Vim is an open source, command line text editor. A use-after-free was found in Vim < 9.1.0764. When closing a buffer (visible in a window) a BufWinLeave auto command can cause an use-after-free if this auto command happens to re-open the same buffer in a new split window. Impact is low since the user must have intentionally set up such a strange auto command and run some buffer unload commands. However this may lead to a crash. This issue has been addressed in version 9.1.0764 and all users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- NetApp Bootstrap Os: all versions
- vim/vim: before 9.1.0764 — fixed in 9.1.0764
How to fix
Upgrade to a fixed version: vim/vim 9.1.0764. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/51b62387be93c65fa56bbabe1c3
- https://github.com/vim/vim/security/advisories/GHSA-rj48-v4mq-j4vg
- https://lists.debian.org/debian-lts-announce/2025/03/msg00023.html
- https://security.netapp.com/advisory/ntap-20250411-0009/
Get alerted when CVE-2024-47814 or the next vulnerability affects your stack