What’s Vulnerable › Vulnerabilities
CVE-2024-47819: Umbraco CMS vulnerable to stored Cross-site Scripting in the "dictionary name" on Dictionary section
- Severity: high (CVSS 8.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-22 · updated 2026-06-17
- Weakness: CWE-79
Description
Umbraco, a free and open source .NET content management system, has a cross-site scripting vulnerability starting in version 14.0.0 and prior to versions 14.3.1 and 15.0.0. This can be leveraged to gain access to higher-privilege endpoints, e.g. if you get a user with admin privileges to run the code, you can potentially elevate all users and grant them admin privileges or access protected content. Versions 14.3.1 and 15.0.0 contain a patch. As a workaround, ensure that access to the Dictionary section is only granted to trusted users.
Affected products
- Umbraco-CMS: from 14.0.0 before 14.3.1 — fixed in 14.3.1
How to fix
Upgrade to a fixed version: Umbraco-CMS 14.3.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-47819 or the next vulnerability affects your stack