What’s Vulnerable › Vulnerabilities
CVE-2024-47829: pnpm uses the md5 path shortening function causes packet paths to coincide, which causes indirect packet overwriting
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-04-23 · updated 2026-06-22
- Weakness: CWE-328
Description
pnpm is a package manager. Prior to version 10.0.0, the path shortening function uses the md5 function as a path shortening compression function, and if a collision occurs, it will result in the same storage path for two different libraries. Although the real names are under the package name /node_modoules/, there are no version numbers for the libraries they refer to. This issue has been patched in version 10.0.0.
Affected products
- pnpm: before 10.0.0 — fixed in 10.0.0
How to fix
Upgrade to a fixed version: pnpm 10.0.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-47829 or the next vulnerability affects your stack