What’s Vulnerable › Vulnerabilities
CVE-2024-4784: Authentication Bypass by Primary Weakness in GitLab
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-08 · updated 2026-06-17
- Weakness: CWE-305
Description
An issue was discovered in GitLab EE starting from version 16.7 before 17.0.6, version 17.1 before 17.1.4 and 17.2 before 17.2.2 that allowed bypassing the password re-entry requirement to approve a policy.
Affected products
- GitLab: from 16.7.0 before 17.0.6; from 17.1.0 before 17.1.4; from 17.2.0 before 17.2.2 — fixed in 17.0.6, 17.1.4, 17.2.2
How to fix
Upgrade to a fixed version: GitLab 17.0.6, 17.1.4, 17.2.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-4784 or the next vulnerability affects your stack