What’s Vulnerable › Vulnerabilities
CVE-2024-47878: Reflected cross-site scripting vulnerability (XSS) in GData extension (authorized.vt)
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-10-24 · updated 2026-06-17
- Weakness: CWE-79
Description
OpenRefine is a free, open source tool for working with messy data. Prior to version 3.8.3, the `/extension/gdata/authorized` endpoint includes the `state` GET parameter verbatim in a `<script>` tag in the output, so without escaping. An attacker could lead or redirect a user to a crafted URL containing JavaScript code, which would then cause that code to be executed in the victim's browser as if it was part of OpenRefine. Version 3.8.3 fixes this issue.
Affected products
- OpenRefine: before 3.8.3 — fixed in 3.8.3
How to fix
Upgrade to a fixed version: OpenRefine 3.8.3. Check the vendor advisory for mitigations.
References
- https://github.com/OpenRefine/OpenRefine/commit/10bf0874d67f1018a58b3732332d76b840192fea
- https://github.com/OpenRefine/OpenRefine/security/advisories/GHSA-pw3x-c5vp-mfc3
Get alerted when CVE-2024-47878 or the next vulnerability affects your stack