What’s Vulnerable › Vulnerabilities
CVE-2024-47887: Action Controller has possible ReDoS vulnerability in HTTP Token authentication
- Severity: medium (CVSS 6.6 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-16 · updated 2026-06-17
- Weakness: CWE-1333
Description
Action Pack is a framework for handling and responding to web requests. Starting in version 4.0.0 and prior to versions 6.1.7.9, 7.0.8.5, 7.1.4.1, and 7.2.1.1, there is a possible ReDoS vulnerability in Action Controller's HTTP Token authentication. For applications using HTTP Token authentication via `authenticate_or_request_with_http_token` or similar, a carefully crafted header may cause header parsing to take an unexpected amount of time, possibly resulting in a DoS vulnerability. All users running an affected release should either upgrade to versions 6.1.7.9, 7.0.8.5, 7.1.4.1, or 7.2.1.1 or apply the relevant patch immediately. One may choose to use Ruby 3.2 as a workaround.Ruby 3.2 has mitigations for this problem, so Rails applications using Ruby 3.2 or newer are unaffected. Rails 8.0.0.beta1 depends on Ruby 3.2 or greater so is unaffected.
Affected products
- Ruby on Rails: from 4.0.0 before 6.1.7.9; from 7.0.0 before 7.0.8.5; from 7.1.0 before 7.1.4.1; from 7.2.0 before 7.2.1.1 — fixed in 6.1.7.9, 7.0.8.5, 7.1.4.1, 7.2.1.1
- Rubygems Actionpack: from 4.0.0 before 6.1.7.9; from 7.0.0 before 7.0.8.5; from 7.1.0 before 7.1.4.1; from 7.2.0 before 7.2.1.1; 4.0.0, 4.0.1, 4.0.1.rc1, 4.0.1.rc2, 4.0.1.rc3, 4.0.1.rc4 (+275) — fixed in 6.1.7.9, 7.0.8.5, 7.1.4.1, 7.2.1.1
How to fix
Upgrade to a fixed version: Ruby on Rails 6.1.7.9, 7.0.8.5, 7.1.4.1, 7.2.1.1; Rubygems Actionpack 6.1.7.9, 7.0.8.5, 7.1.4.1, 7.2.1.1. Check the vendor advisory for mitigations.
References
- https://github.com/rails/rails/commit/56b2fc3302836405b496e196a8d5fc0195e55049
- https://github.com/rails/rails/commit/7c1398854d51f9bb193fb79f226647351133d08a
- https://github.com/rails/rails/commit/8e057db25bff1dc7a98e9ae72e0083825b9ac545
- https://github.com/rails/rails/commit/f4dc83d8926509d0958ec21fcdbc2e7df3d32ce2
- https://github.com/rails/rails/security/advisories/GHSA-vfg9-r3fq-jvx4
Get alerted when CVE-2024-47887 or the next vulnerability affects your stack