What’s Vulnerable › Vulnerabilities
CVE-2024-47888: Action Text has possible ReDoS vulnerability in plain_text_for_blockquote_node
- Severity: medium (CVSS 6.6 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-16 · updated 2026-06-17
- Weakness: CWE-1333
Description
Action Text brings rich text content and editing to Rails. Starting in version 6.0.0 and prior to versions 6.1.7.9, 7.0.8.5, 7.1.4.1, and 7.2.1.1, there is a possible ReDoS vulnerability in the `plain_text_for_blockquote_node helper` in Action Text. Carefully crafted text can cause the `plain_text_for_blockquote_node` helper to take an unexpected amount of time, possibly resulting in a DoS vulnerability. All users running an affected release should either upgrade to versions 6.1.7.9, 7.0.8.5, 7.1.4.1, or 7.2.1.1 or apply the relevant patch immediately. As a workaround, users can avoid calling `plain_text_for_blockquote_node` or upgrade to Ruby 3.2. Ruby 3.2 has mitigations for this problem, so Rails applications using Ruby 3.2 or newer are unaffected. Rails 8.0.0.beta1 depends on Ruby 3.2 or greater so is unaffected.
Affected products
- Rails: from 6.0.0 before 6.1.7.9; from 7.0.0 before 7.0.8.5; from 7.1.0 before 7.1.4.1; from 7.2.0 before 7.2.1.1 — fixed in 6.1.7.9, 7.0.8.5, 7.1.4.1, 7.2.1.1
How to fix
Upgrade to a fixed version: Rails 6.1.7.9, 7.0.8.5, 7.1.4.1, 7.2.1.1. Check the vendor advisory for mitigations.
References
- https://github.com/rails/rails/commit/4f4312b21a6448336de7c7ab0c4d94b378def468
- https://github.com/rails/rails/commit/727b0946c3cab04b825c039435eac963d4e91822
- https://github.com/rails/rails/commit/ba286c0a310b7f19cf5cac2a7a4c9def5cf9882e
- https://github.com/rails/rails/commit/de0df7caebd9cb238a6f10dca462dc5f8d5e98b5
- https://github.com/rails/rails/security/advisories/GHSA-wwhv-wxv9-rpgw
Get alerted when CVE-2024-47888 or the next vulnerability affects your stack